<!DOCTYPE html>



<html lang="en" class="fontface display-table">
    <head>
        <meta charset="utf-8"><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,n,t){function r(t){if(!n[t]){var o=n[t]={exports:{}};e[t][0].call(o.exports,function(n){var o=e[t][1][n];return r(o||n)},o,o.exports)}return n[t].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<t.length;o++)r(t[o]);return r}({1:[function(e,n,t){function r(){}function o(e,n,t){return function(){return i(e,[c.now()].concat(u(arguments)),n?null:this,t),n?void 0:this}}var i=e("handle"),a=e(2),u=e(3),f=e("ee").get("tracer"),c=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,n){s[n]=o(d+n,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),n.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,n){var t={},r=this,o="function"==typeof n;return i(l+"tracer",[c.now(),e,t],r),function(){if(f.emit((o?"":"no-")+"fn-start",[c.now(),r,o],t),o)try{return n.apply(this,arguments)}finally{f.emit("fn-end",[c.now()],t)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,n){m[n]=o(l+n)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,c.now()])}},{}],2:[function(e,n,t){function r(e,n){var t=[],r="",i=0;for(r in e)o.call(e,r)&&(t[i]=n(r,e[r]),i+=1);return t}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],3:[function(e,n,t){function r(e,n,t){n||(n=0),"undefined"==typeof t&&(t=e?e.length:0);for(var r=-1,o=t-n||0,i=Array(o<0?0:o);++r<o;)i[r]=e[n+r];return i}n.exports=r},{}],4:[function(e,n,t){n.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,n,t){function r(){}function o(e){function n(e){return e&&e instanceof r?e:e?f(e,u,i):i()}function t(t,r,o,i){if(!d.aborted||i){e&&e(t,r,o);for(var a=n(o),u=m(t),f=u.length,c=0;c<f;c++)u[c].apply(a,r);var p=s[y[t]];return p&&p.push([b,t,r,a]),a}}function l(e,n){v[e]=m(e).concat(n)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(t)}function g(e,n){c(e,function(e,t){n=n||"feature",y[t]=n,n in s||(s[n]=[])})}var v={},y={},b={on:l,emit:t,get:w,listeners:m,context:n,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",f=e("gos"),c=e(2),s={},p={},d=n.exports=o();d.backlog=s},{}],gos:[function(e,n,t){function r(e,n,t){if(o.call(e,n))return e[n];var r=t();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,n,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[n]=r,r}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],handle:[function(e,n,t){function r(e,n,t,r){o.buffer([e],r),o.emit(e,n,t)}var o=e("ee").get("handle");n.exports=r,r.ee=o},{}],id:[function(e,n,t){function r(e){var n=typeof e;return!e||"object"!==n&&"function"!==n?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");n.exports=r},{}],loader:[function(e,n,t){function r(){if(!x++){var e=h.info=NREUM.info,n=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&n))return s.abort();c(y,function(n,t){e[n]||(e[n]=t)}),f("mark",["onload",a()+h.offset],null,"api");var t=d.createElement("script");t.src="https://"+e.agent,n.parentNode.insertBefore(t,n)}}function o(){"complete"===d.readyState&&i()}function i(){f("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),f=e("handle"),c=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1026.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=n.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),f("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","queueTime":0,"licenseKey":"444c683d22","agent":"","transactionName":"ZAYDYkdTXRUAVkUNW11MJ0NbUUcPDlseE1FdFA5EWVYdEAhQRhcOcAICXlBWchQVXFIIUXcGFVdcXh0BBEE=","applicationID":"22952072","errorBeacon":"bam.nr-data.net","applicationTime":122}</script>
        <title>Huskies&amp;#8217; season ends with Pac-12 tournament loss to USC</title>
        


        <meta name="viewport" content="width=device-width, initial-scale=1.0">

        <meta property="og:title" content="Huskies&#8217; season ends with Pac-12 tournament loss to USC">
        <meta property="og:description" content="LAS VEGAS &mdash; It's over. Finally, mercifully, after 13 consecutive losses and counting, after so many empty offensive possessions and so many turnovers and so much lackluster defense, the Washington ...">
        <meta property="og:url" content="http://www.wenatcheeworld.com/news/2017/mar/10/huskies8217-season-ends-with-pac-12-tournament-loss-to-usc/">
        <meta property="og:type" content="article">
        <meta property="og:image" content="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/10/57b2cc6e75-pic-30412583.jpg.960x720_q80.jpg">
        <script type="application/ld+json">
        {
          "@context" : "http://schema.org",
          "@type" : "NewsArticle",
          "name" : "Huskies&#8217; season ends with Pac-12 tournament loss to USC",
          "author" : {
            "@type" : "Person",
            "name" : "Christian Caple





The (Tacoma) News Tribune"
          },
          "mainEntityOfPage" : "www.wenatcheeworld.com/news/2017/mar/10/huskies8217-season-ends-with-pac-12-tournament-loss-to-usc/",
          "datePublished" : "2017-03-10T07:08:00-08:00",
          "dateModified" : "2017-03-10T07:18:08.298052-08:00",
          "articleSection" : "Sports News",
          "articleBody" : "LAS VEGAS &mdash; It's over. Finally, mercifully, after 13 consecutive losses and counting, after so many empty offensive possessions and so many turnovers and so much lackluster defense, the Washington Huskies are finished with this mess of a men&rsquo;s basketball season. They laid the catastrophe to rest with another inevitable defeat, this one 78-73 to the USC Trojans on Wednesday night in the first round of the Pac-12 tournament at the mostly empty T-Mobile Arena, 49 days now separating them&hellip;",
          "url" : "http://www.wenatcheeworld.com/news/2017/mar/10/huskies8217-season-ends-with-pac-12-tournament-loss-to-usc/",
          "headline" : "Huskies&#8217; season ends with Pac-12 tournament loss to USC",
          "image" : "https://s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/10/57b2cc6e75-pic-30412583.jpg.960x720_q80.jpg",
          "publisher" : {
            "@type" : "Organization",
            "name" : "The Wenatchee World",
            "logo" : "http://s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/WW-logo-small.png"
          }
        }
        </script>



        <!-- Le styles -->
        <link rel="alternate" type="application/rss+xml" title=" Top Stories" href="/rss/headlines/local-news/">
        <link href="//netdna.bootstrapcdn.com/font-awesome/4.1.0/css/font-awesome.min.css" rel="stylesheet">
        <link href='//fonts.googleapis.com/css?family=Open+Sans+Condensed:700|News+Cycle:700|Open+Sans:300' rel='stylesheet' type='text/css'>
        <link rel="stylesheet" href="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/CACHE/css/a2765a570d1c.css" type="text/css" />

        <!-- Le HTML5 shim, for IE6-8 support of HTML5 elements -->
        <!--[if lt IE 9]>
            <script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
        <![endif]-->

        <!-- Le fav and touch icons -->
        <link rel="shortcut icon" href="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ico/favicon.ico">
        <link rel="apple-touch-icon-precomposed" sizes="144x144" href="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ico/apple-touch-icon-ipad3.png">
        <link rel="apple-touch-icon-precomposed" sizes="114x114" href="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ico/apple-touch-icon-iphone4.png">
        <link rel="apple-touch-icon-precomposed" sizes="72x72" href="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ico/apple-touch-icon-ipad.png">
        <link rel="apple-touch-icon-precomposed" href="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ico/apple-touch-icon-iphone.png">
        
    <link rel="stylesheet" href="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/CACHE/css/a9abbc8725d4.css" type="text/css" /><link rel="stylesheet" href="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/CACHE/css/878e9b6eeded.css" type="text/css" media="screen" /><link rel="stylesheet" href="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/CACHE/css/bd2526d21625.css" type="text/css" /><link rel="stylesheet" href="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/CACHE/css/192ed7f19557.css" type="text/css" media="print" /><link rel="stylesheet" href="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/CACHE/css/a15b427c9f3b.css" type="text/css" />
    
    <!--[if lt IE 9]>
    <style type="text/css">
    #img-layer .lgcap, .fancybox-title-float-wrap .child {
        background: url('//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/fancybox/fancybox_overlay.png') !important;
    }
    </style>
    <![endif]-->


        
        <script src="//ajax.googleapis.com/ajax/libs/jquery/1.8.1/jquery.min.js"></script>
        <script src='https://www.google.com/recaptcha/api.js'></script>
        
    <script type="text/javascript" src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/CACHE/js/699718a76a71.js"></script>


        
<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
    
        googletag.defineSlot('/1678726/WWPW_Leaderboard_Story_728x90', [728, 90], 'div-gpt-ad-1469117380559-0').addService(googletag.pubads());
        googletag.defineSlot('/1678726/WW_Bigbox_Story_300x250', [300, 250], 'div-gpt-ad-1469117380559-1').addService(googletag.pubads());
        googletag.defineSlot('/1678726/WW_Bigbox_Story_ROS_300x250', [300, 250], 'div-gpt-ad-1469117380559-2').addService(googletag.pubads());
        googletag.defineSlot('/1678726/WW_Bigbox_Story_House_300x250', [300, 250], 'div-gpt-ad-1469117380559-3').addService(googletag.pubads());
    
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs(); // hide ad units when empty.
    googletag.enableServices();
  });
</script>


        <script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-6276412-14', 'wenatcheeworld.com');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script>
        
    </head>

    <body class="article-detail" id="">
        <div id="contain">
        <!--[if lte IE 7]>
        <div class="alert alert-error alert-ie">
            <button type="button" class="close" data-dismiss="alert">×</button>
            <strong>Your browser is out of date.</strong> It has known security flaws and may not display all the features of this and other websites. <a href="http://whatbrowser.org/" target="_blank">Upgrade now!</a>
        </div>
        <![endif]-->
        
        
        <header id="masthead">
            
            <div class="logo-ww">
                <h1><a href="/"><img alt="The Wenatchee World" src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/WW-logo.png"></a></h1>
                <p class="todays-date">
                    <time datetime="2017-03-10">
                    <span class="day">Friday, </span>
                    March 10, 2017</time>
                </p>
            </div>
            <div class="weather">
                <h2 class="dd-head">Weather:</h2>
                
<div class="current-conditions">
    <div class="icon"><a onclick="expand_weather();"><span class="wicon w27"></span></a></div>
    <div class="temp"><a onclick="expand_weather();">34&deg;</a></div>
    <p class="forecast-link"><a onclick="expand_weather();" data-target="#masthead" data-after="/data/weather-menu-test/" class="weather-info">Forecast</a></p>
</div>

            </div>
            <div class="my-verticals">
                <div class="vt-links mini-menu">
                    <nav>
                        <div class="triangle collapsible-content-collapsed"></div>
                        <p class="title">Classifieds<i>:</i></p>
                        <ul class="stub-open collapsible-content-collapsed">
<!--                             <li><a href="http://autofinder.wenatcheeworld.com">Autos</a></li>
 -->                            <li><a href="http://homes.wenatcheeworld.com">Homes</a></li>
                            <li><a href="http://classifieds.wenatcheeworld.com/wenatchee/employment/search">Jobs</a></li>
                            <li><a href="http://ncwbusinessdirectory.com">Businesses</a></li>
                            <li><a href="http://classifieds.wenatcheeworld.com">Classifieds</a></li>
                            <li class="last"><a href="/digital/">Digital Edition</a></li>
                        </ul>
                    </nav>
                </div>
                
            </div>
            <nav class="utils">
                
                <div id="subscribe-wrap" class="btn-group pull-left my-account">
                    <a href="/subscribe/">Subscribe</a>
                    <a href="/make-payment/">Make a Payment</a>
                </div>
                
                
                <div id="signin-wrap">
                    <div class="signin-user">
                        <a class="sign-in" href="/accounts/signin/">Sign In</a>
                    </div>
                </div>
                
                
            </nav>
            <div class="nav-primary">
                <form method="get" class="search main-search" action="/search/">
                    <fieldset>
                        <label for="q">
                            Search:
                        </label>
                        <div class="search-inputs">
                            <div>
                                <input type="text" placeholder="Search" id="q" name="q" class="search">
                                <input type="submit" value="Go" class="submit">
                            </div>
                        </div>
                    </fieldset>
                </form>
                <!-- submenu content -->
                <nav data-menu-content="includes/mega-menu.html" class="sections collapsible-collapsed nav-menu">
                    <h1 class="sections-heading collapsible-heading collapsible-heading-collapsed"><a class="collapsible-heading-toggle" href="#" title="Expand to see more">
                        Sections
                        <span class="collapsible-heading-status"></span></a></h1>

                    

                    



<ul class="collapsible-content collapsible-content-collapsed menulist" aria-hidden="true">
    
    
    <li data-section="News" class="News mainmenu"><a href="/news/news/" id="topnav-btnlabel-1" role="button"  aria-haspopup="true" aria-owns="topnav-menu-1" aria-expanded="false" aria-label="News page. Click to visit, or use arrow keys to enter and leave menu.">News</a></li>
    
    
    
    <li data-section="Sports" class="Sports mainmenu"><a href="/news/sports/" id="topnav-btnlabel-2" role="button"  aria-haspopup="true" aria-owns="topnav-menu-2" aria-expanded="false" aria-label="Sports page. Click to visit, or use arrow keys to enter and leave menu.">Sports</a></li>
    
    
    
    <li data-section="Opinion" class="Opinion mainmenu"><a href="/news/opinion/" id="topnav-btnlabel-3" role="button"  aria-haspopup="true" aria-owns="topnav-menu-3" aria-expanded="false" aria-label="Opinion page. Click to visit, or use arrow keys to enter and leave menu.">Opinion</a></li>
    
    
    
    <li data-section="Obituaries" class="Obituaries mainmenu"><a href="/news/obituaries/" id="topnav-btnlabel-4" role="button"  aria-haspopup="true" aria-owns="topnav-menu-4" aria-expanded="false" aria-label="Obituaries page. Click to visit, or use arrow keys to enter and leave menu.">Obituaries</a></li>
    
    
    
    <li data-section="Go!" class="Go! mainmenu"><a href="/news/go/" id="topnav-btnlabel-5" role="button"  aria-haspopup="true" aria-owns="topnav-menu-5" aria-expanded="false" aria-label="Go! page. Click to visit, or use arrow keys to enter and leave menu.">Go!</a></li>
    
    
    
    <li data-section="Lifestyle" class="Lifestyle mainmenu"><a href="/news/lifestyle/" id="topnav-btnlabel-6" role="button"  aria-haspopup="true" aria-owns="topnav-menu-6" aria-expanded="false" aria-label="Lifestyle page. Click to visit, or use arrow keys to enter and leave menu.">Lifestyle</a></li>
    
    
    
    
    <li data-section="multimedia" class="multimedia mainmenu"><a href="/photos/" id="topnav-btnlabel-7" role="button" aria-haspopup="true" aria-owns="topnav-menu-7" aria-expanded="false" aria-label="Multimedia section. Click to visit, or use arrow keys to enter and leave menu.">Media</a></li>
    <li data-section="blogs" class="blogs mainmenu last"><a href="/blogs/" id="topnav-btnlabel-8" class="last" role="button"  aria-haspopup="true" aria-owns="topnav-menu-8" aria-expanded="false" aria-label="Blogs section. Click to visit, or use arrow keys to enter and leave menu.">Blogs</a></li>
</ul>

                    
            




<div id="topnav-menu-1" class="menu inside" data-menu="news">
    <div class="content">
        
        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/09/high-tech-parking-patrol-hits-the-streets/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/09/8a36b0f270-pic-30409199.jpg.170x170_q80_crop-crop.jpg" alt="High-tech parking patrol hits the streets" />
                
                <h4 class="story-title">High-tech parking patrol hits the&nbsp;streets</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/09/teacher-hunt-starts-early/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/secs/general200w.jpg" alt="Teacher hunt starts early" />
                
                <h4 class="story-title">Teacher hunt starts&nbsp;early</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/09/group-launches-campaign-to-oppose-chelan-hospital-bond/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/10/f829de1bdc-pic-30399721.jpg.170x170_q80_crop-crop.jpg" alt="Hospital bond opponents make their case..." />
                
                <h4 class="story-title">Hospital bond opponents make their&nbsp;case&#8230;</h4>
            </a>
        </div>

        <div class="latest-headlines">
            <nav>
                <h1 class="mm-head">More Headlines</h1>
                <ul>
                
<li><a href="/news/2017/mar/09/hospital-proponents-respond-to-concerns/">&#8230;while backers say it&#8217;s&nbsp;time&nbsp;</a></li>
<li><a href="/news/2017/mar/09/repwatch-the-green-green-grass-of-home/">RepWatch | The green, green grass of&nbsp;home&nbsp;</a></li>
<li><a href="/news/2017/mar/10/old-news-change-of-command-at-the-state-patrol/">Old news | Change of command at the State&nbsp;Patrol&nbsp;</a></li>
<li><a href="/news/2017/mar/10/methow-forms-new-housing-group/">Methow forms new housing&nbsp;group&nbsp;</a></li>
<li><a href="/news/2017/mar/10/ncw-whitefish-season-closes/"><span class="caps">NCW</span> whitefish season&nbsp;closes&nbsp;</a></li>
                </ul>
            </nav>
        </div>
        

        




<div class="menu-more">
    <nav>
        <h1 class="mm-head">Other News</h1>
        
        <ul>
            
            
            <li><a href="/news/news/northwest/">Northwest</a></li>
            
            
            
            <li><a href="/news/news/local/">Local</a></li>
            
            
            
            <li><a href="/news/news/national/">National</a></li>
            
            
            
            <li><a href="/news/news/world/">World</a></li>
            
            
            
            <!-- replace elections category page with elections website link -->
            <li><a href="http://elections.wenatcheeworld.com" target="_blank">Elections</a></li>
            
            
            
            <li><a href="/news/news/business/">Business</a></li>
            
            
        </ul>
        
    </nav>
</div>


    </div>
    <span class="menu-close"></span>
</div>


<div id="topnav-menu-2" class="menu inside" data-menu="sports">
    <div class="content">
        
        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/09/winter-2017-collegians-how-they-fared/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/10/fbb4c90a47-pic-30417632.jpg.170x170_q80_crop-crop.jpg" alt="Winter 2017 collegians: How they fared" />
                
                <h4 class="story-title">Winter 2017 collegians: How they&nbsp;fared</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/07/north-central-washington-winter-all-league-teams/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/07/f7c69dc7c2-pic-30304127.jpg.170x170_q80_crop-crop.jpg" alt="North Central Washington winter all-league teams" />
                
                <h4 class="story-title">North Central Washington winter all-league&nbsp;teams</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/05/wild-get-their-fillwenatchee-beats-prince-george-6-1-to-take-2-0-series-lead/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/06/c944038c08-352017-wild-playoff-17.jpg.170x170_q80_crop-crop.jpg" alt="Wild get their fill | Wenatchee beats Prince George 6-1 to take 2-0 series lead" />
                
                <h4 class="story-title">Wild get their fill | Wenatchee beats Prince George 6-1 to take 2-0 series&nbsp;lead</h4>
            </a>
        </div>

        <div class="latest-headlines">
            <nav>
                <h1 class="mm-head">More Headlines</h1>
                <ul>
                
<li><a href="/news/2017/mar/04/townsend-goes-off-okanogan-takes-third/">Townsend goes off, Okanogan takes&nbsp;third&nbsp;</a></li>
<li><a href="/news/2017/mar/10/huskies8217-season-ends-with-pac-12-tournament-loss-to-usc/">Huskies&#8217; season ends with Pac-12 tournament loss to&nbsp;<span class="caps">USC</span>&nbsp;</a></li>
<li><a href="/news/2017/mar/10/texans-trade-osweiler-to-browns/">Texans trade Osweiler to&nbsp;Browns&nbsp;</a></li>
<li><a href="/news/2017/mar/10/eagles-sign-wr-jeffery/">Eagles sign <span class="caps">WR</span>&nbsp;Jeffery&nbsp;</a></li>
<li><a href="/news/2017/mar/10/cowboys-shopping-romo-no-plan-to-release-qb/">Cowboys shopping Romo, no plan to release&nbsp;<span class="caps">QB</span>&nbsp;</a></li>
                </ul>
            </nav>
        </div>
        

        




<div class="menu-more">
    <nav>
        <h1 class="mm-head">Other Sports</h1>
        
        <ul>
            
            
            <li><a href="/news/sports/professional/">Professional</a></li>
            
            
            
            <li><a href="/news/sports/local/">Local</a></li>
            
            
            
            <li><a href="/news/sports/hs/">High School</a></li>
            
            
            
            <li><a href="/news/sports/national/">National</a></li>
            
            
            
            <li><a href="/news/sports/rec/">Rec</a></li>
            
            
        </ul>
        
    </nav>
</div>


    </div>
    <span class="menu-close"></span>
</div>


<div id="topnav-menu-3" class="menu inside" data-menu="opinion">
    <div class="content">
        
        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/feb/26/immigrants-face-a-world-of-fear/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/secs/general200w.jpg" alt="Editorial Board | Immigrants face a world of fear" />
                
                <h4 class="story-title">Editorial Board | Immigrants face a world of&nbsp;fear</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/feb/26/teaching-for-jobs/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/secs/general200w.jpg" alt="Editorial Board | Teaching for jobs" />
                
                <h4 class="story-title">Editorial Board | Teaching for&nbsp;jobs</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/feb/26/no-headline/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/secs/general200w.jpg" alt="Safety Valve | Letters from readers" />
                
                <h4 class="story-title">Safety Valve | Letters from&nbsp;readers</h4>
            </a>
        </div>

        <div class="latest-headlines">
            <nav>
                <h1 class="mm-head">More Headlines</h1>
                <ul>
                
<li><a href="/news/2017/mar/09/we-have-letters-thanks-to-trump/">Tracy Warner | We have letters, thanks to&nbsp;Trump&nbsp;</a></li>
<li><a href="/news/2017/mar/09/eugenics-was-a-progressive-cause/">George Will | Eugenics was a progressive&nbsp;cause&nbsp;</a></li>
<li><a href="/news/2017/mar/09/safety-valve-letters-from-readers/">Safety Valve: Letters from&nbsp;readers&nbsp;</a></li>
<li><a href="/news/2017/mar/08/safety-valve-letters-from-readers/">Safety Valve: Letters from&nbsp;readers&nbsp;</a></li>
<li><a href="/news/2017/mar/08/tracy-warner-soon-to-retire/">Tracy Warner soon to&nbsp;retire&nbsp;</a></li>
                </ul>
            </nav>
        </div>
        

        
        <div class="menu-more">
            <nav>
                <h1 class="mm-head">Other Opinion</h1>
                <ul>
                    <li><a href="/solutions/">Local Solutions</a></li>
                </ul>
            </nav>
        </div>
   </div>
    <span class="menu-close"></span>
</div>


<div id="topnav-menu-4" class="menu inside" data-menu="obituaries">
    <div class="content">
        
        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/09/phillip-r-wood/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/secs/general200w.jpg" alt="Phillip R. Wood" />
                
                <h4 class="story-title">Phillip R.&nbsp;Wood</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/09/funeral-service-directory/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/secs/general200w.jpg" alt="Funeral Service Directory" />
                
                <h4 class="story-title">Funeral Service&nbsp;Directory</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/09/william-f-joaquin-cleveland/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/secs/general200w.jpg" alt="William F. &#39;Joaquin&#39; Cleveland" />
                
                <h4 class="story-title">William F. &#8216;Joaquin&#8217;&nbsp;Cleveland</h4>
            </a>
        </div>

        <div class="latest-headlines">
            <nav>
                <h1 class="mm-head">More Headlines</h1>
                <ul>
                
<li><a href="/news/2017/mar/09/michael-l-de-mars/">Michael L. de&nbsp;Mars&nbsp;</a></li>
<li><a href="/news/2017/mar/09/alonzo-lee-holland/">Alonzo Lee&nbsp;Holland&nbsp;</a></li>
<li><a href="/news/2017/mar/09/michelle-lynn-stevens/">Michelle Lynn&nbsp;Stevens&nbsp;</a></li>
<li><a href="/news/2017/mar/09/victor-j-moir/">Victor J.&nbsp;Moir&nbsp;</a></li>
<li><a href="/news/2017/mar/08/ayn-marie-bahr/">Ayn Marie&nbsp;Bahr&nbsp;</a></li>
                </ul>
            </nav>
        </div>
        

        





    </div>
    <span class="menu-close"></span>
</div>


<div id="topnav-menu-5" class="menu inside" data-menu="arts">
    <div class="content">
        
        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/09/vox-docs-festival-2017/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/08/92f85a11fc-pic-30350866.jpg.170x170_q80_crop-crop.jpg" alt="Vox Docs Festival brings popular documentaries and special guests to Leavenworth" />
                
                <h4 class="story-title">Vox Docs Festival brings popular documentaries and special guests to&nbsp;Leavenworth</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/09/clare-barron-wins-blackburn/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/08/8933828bfc-pic-30357030.jpg.170x170_q80_crop-crop.jpg" alt="Wenatchee playwright Clare Barron wins national award" />
                
                <h4 class="story-title">Wenatchee playwright Clare Barron wins national&nbsp;award</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/09/briefly-030917/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/08/de2bf8d594-pic-30350860.jpg.170x170_q80_crop-crop.jpg" alt="Briefly: Appleaires concert and &quot;Stage Door&quot;" />
                
                <h4 class="story-title">Briefly: Appleaires concert and &#8220;Stage&nbsp;Door&#8221;</h4>
            </a>
        </div>

        <div class="latest-headlines">
            <nav>
                <h1 class="mm-head">More Headlines</h1>
                <ul>
                
<li><a href="/news/2017/mar/09/check-it-out-our-arts-and-entertainment-picks-for-the-week/">Check it out: Our arts and entertainment picks for the&nbsp;week&nbsp;</a></li>
<li><a href="/news/2017/mar/09/the-planner030917/">The&nbsp;Planner&nbsp;</a></li>
<li><a href="/news/2017/mar/09/flick-picks030917/">Flick Picks: Movie show times for March&nbsp;10-16&nbsp;</a></li>
<li><a href="/news/2017/mar/09/night-out0301917/">Night Out: Clubs and pubs with&nbsp;entertainment&nbsp;</a></li>
<li><a href="/news/2017/mar/02/edm-antigone-brings-reimagined-classic-to-students/">Ancient literature, modern sound: &#8216;<span class="caps">EDM</span> Antigone&#8217; brings reimagined classic to&nbsp;students&nbsp;</a></li>
                </ul>
            </nav>
        </div>
        

        




<div class="menu-more">
    <nav>
        <h1 class="mm-head">Other Go!</h1>
        
        <ul>
            
            
            <li><a href="/news/go/arts/">Arts</a></li>
            
            
            
            <li><a href="/news/go/music/">Music</a></li>
            
            
            
            <li><a href="/news/go/events/">Events</a></li>
            
            
            
            <li><a href="/news/go/movies/">Movies</a></li>
            
            
        </ul>
        
    </nav>
</div>


    </div>
    <span class="menu-close"></span>
</div>


<div id="topnav-menu-6" class="menu inside" data-menu="lifestyle">
    <div class="content">
        
        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/10/turns-and-smiles-leavenworths-afterschool-ski-and-snowboard-program-remains-a-big-hit/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/10/07fa36308f-pic-30296723.jpg.170x170_q80_crop-crop.jpg" alt="Turns and smiles: Leavenworth&#39;s Afterschool Ski and Snowboard Program remains a big hit" />
                
                <h4 class="story-title">Turns and smiles: Leavenworth&#8217;s Afterschool Ski and Snowboard Program remains a big&nbsp;hit</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/10/frank-cone-wall-of-snow/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/10/ecefcaec81-pic-30301477.jpg.170x170_q80_crop-crop.jpg" alt="Frank Cone | Wall of Snow" />
                
                <h4 class="story-title">Frank Cone | Wall of&nbsp;Snow</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/news/2017/mar/10/annual-kids-expo-features-live-entertainment-activities/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/secs/general200w.jpg" alt="Annual kids expo features live entertainment, activities" />
                
                <h4 class="story-title">Annual kids expo features live entertainment,&nbsp;activities</h4>
            </a>
        </div>

        <div class="latest-headlines">
            <nav>
                <h1 class="mm-head">More Headlines</h1>
                <ul>
                
<li><a href="/news/2017/mar/10/how-to-cope-when-children-seek-a-new-faith/">How to cope when children seek a new&nbsp;faith&nbsp;</a></li>
<li><a href="/news/2017/mar/10/dear-abby-womans-younger-boyfriend-hides-her-from-his-family/">Dear Abby | Woman&#8217;s younger boyfriend hides her from his&nbsp;family&nbsp;</a></li>
<li><a href="/news/2017/mar/10/college-life/">College&nbsp;life&nbsp;</a></li>
<li><a href="/news/2017/mar/10/the-first-rule-of-sports-parenting-dont-speak/">The first rule of sports, parenting: Don&#8217;t&nbsp;speak&nbsp;</a></li>
<li><a href="/news/2017/mar/10/book-club-to-meet-march-16/">Book club to meet March&nbsp;16&nbsp;</a></li>
                </ul>
            </nav>
        </div>
        

        




<div class="menu-more">
    <nav>
        <h1 class="mm-head">Other Lifestyle</h1>
        
        <ul>
            
            
            <li><a href="/news/lifestyle/food/">Food</a></li>
            
            
            
            <li><a href="/news/lifestyle/neighbors/">Neighbors</a></li>
            
            
            
            <li><a href="/news/lifestyle/at-home/">At Home</a></li>
            
            
            
            <li><a href="/news/lifestyle/health/">Health</a></li>
            
            
            
            <li><a href="/news/lifestyle/family-faith/">Family &amp; Faith</a></li>
            
            
            
            <li><a href="/news/lifestyle/your-news/">Your News</a></li>
            
            
        </ul>
        
    </nav>
</div>


    </div>
    <span class="menu-close"></span>
</div>



<div id="topnav-menu-7" class="menu inside" data-menu="multimedia">
    <div class="content">
        
        
        <div class="menu-feature feat-thumb">
            <h1 class="mm-head">videos</h1>
            <a href="/videos/2017/mar/01/tonaksket-coach-teacher-incident/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/video/2017/03/01/f4bf6167b2-tonaksket-coach-teacher-incident.jpg.170x170_q80_crop-crop.jpg" alt="Tonasket coach-teacher incident" />
                
                <h4 class="story-title">Tonasket coach-teacher incident</h4>
            </a>
        </div>
        
        
        
        <div class="menu-feature feat-thumb">
            <h1 class="mm-head">photos</h1>
            <a href="/photos/galleries/2017/mar/06/photo-gallery-wenatchee-wild-hockey-beats-prince-george/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/06/e1218eff57-352017-wild-playoff-04.jpg.170x170_q80_crop-crop.jpg" alt="Photo Gallery: Wenatchee Wild Hockey beats Prince George" />
                
                <h4 class="story-title">Photo Gallery: Wenatchee Wild Hockey beats Prince George</h4>
            </a>
        </div>
        
        <div class="menu-feature feat-thumb">
            <h1 class="mm-head">photos</h1>
            <a href="/photos/galleries/2017/mar/04/photo-gallery-cashmere-girls-championship-game/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/photo/2017/03/04/0a9563b2ff-342017-cashmerestate-07.jpg.170x170_q80_crop-crop.jpg" alt="Photo Gallery: Cashmere girls in championship game" />
                
                <h4 class="story-title">Photo Gallery: Cashmere girls in championship game</h4>
            </a>
        </div>
        <div class="latest-headlines">
            <nav>
                <h1 class="mm-head">More Galleries</h1>
                <ul>
                <li><a href="/photos/galleries/2017/mar/01/photo-gallery-brewster-boys-basketball/">Photo Gallery: Brewster boys basketball</a></li><li><a href="/photos/galleries/2017/feb/26/photo-gallery-okanogan-and-cashmere-girls-basketball-win-regional-games/">Photo Gallery: Okanogan and Cashmere girls basketball win regional games</a></li><li><a href="/photos/galleries/2017/feb/20/photo-gallery-day-senator-brad-hawkins/">Photo Gallery: A day with Senator Brad Hawkins</a></li><li><a href="/photos/galleries/2017/feb/12/photo-gallery-wilf-through-years/">Photo Gallery: Wilf through the years</a></li><li><a href="/photos/galleries/2017/feb/11/photo-gallery-apple-blossom-royalty-selection-pageant/">Photo Gallery: Apple Blossom Royalty Selection Pageant </a></li>
                </ul>
            </nav>
        </div>
        

        <div class="menu-more">
            <nav>
                <h1 class="mm-head">Other Multimedia</h1>
                <ul>
                    <li><a href="/videos/">Latest Videos</a></li>
                    <li><a href="/photos/">Latest Photos</a></li>
                    <li><a href="/photos/galleries/">Photo Galleries</a></li>
                    <li><a href="/photos/uploads/">Share Your Photos</a></li>
                    <li><a href="/webcams/">Webcams</a>
                </ul>
            </nav>
        </div>
    </div>
    <span class="menu-close"></span>
</div>


<div id="topnav-menu-8" class="menu inside" data-menu="blogs">
    <div class="content">
        
        
        <div class="menu-feature feat-thumb">
            <a href="/blogs/bruce-report/2017/mar/08/wvc-baseball-and-softball-to-give-it-another-try-this-weekend/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/secs/general200w.jpg" alt="WVC baseball and softball to give it another try this weekend" />
                
                <h4 class="story-title">WVC baseball and softball to give it another try this weekend</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/blogs/winemakers-journal/2017/mar/08/winemakers-journal-10-wines-50/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/media/img/blog-photo/2017/03/08/0adafa5125-cheap-wines.jpg.170x170_q80_crop-crop.jpg" alt="" />
                
                <h4 class="story-title">Winemakers Journal: 10 wines for $50</h4>
            </a>
        </div>

        
        <div class="menu-feature feat-thumb">
            <a href="/blogs/bruce-report/2017/mar/07/soccer-and-golf-begin-panther-spring-sports-this-wintery-week/">
                
                <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/secs/general200w.jpg" alt="Soccer and golf begin Panther &quot;spring&quot; sports this &quot;wintery&quot; week" />
                
                <h4 class="story-title">Soccer and golf begin Panther &quot;spring&quot; sports this &quot;wintery&quot; week</h4>
            </a>
        </div>

        <div class="latest-headlines">
            <nav>
                <h1 class="mm-head">More Headlines</h1>
                <ul>
                <li><a href="/blogs/everyday-business/2017/mar/03/everyday-business-we-tried-taco-bells-naked-chicken-chalupa-and-hey-its-pretty-good/">Everyday Business | We tried Taco Bell&#39;s Naked Chicken Chalupa and, hey, it&#39;s pretty good</a></li><li><a href="/blogs/winemakers-journal/2017/mar/03/winemakers-journal-record-grape-crop/">Winemaker&#39;s Journal | Record grape crop</a></li><li><a href="/blogs/community-connections/2017/mar/03/teri-fink-museum-offers-ice-age-experience-3000-students/">Teri Fink | Museum offers ice age experience to 3,000 students</a></li><li><a href="/blogs/faith-and-values/2017/mar/03/greg-asimakoupoulos-winning-game-plan/">Greg Asimakoupoulos | A winning game plan</a></li><li><a href="/blogs/everyday-business/2017/mar/02/radioshack-pull-plug/">Everyday Business | RadioShack to pull the plug</a></li>
                </ul>
            </nav>
        </div>
        
        <div class="menu-more">
            <nav>
                <h1 class="mm-head">Other Blogs</h1>
                <ul>
                    <li><a href="/blogs/">Index</a></li>
                    <li><a href="/blogs/category/issues/community-connections">Community Connections</a></li>
                    <li><a href="/blogs/list/">Blog Directory</a></li>
                    <li><a href="/blogs/staff/">Staff Blogs</a></li>
                    <li><a href="/blogs/posts/">Recent Posts</a></li>
                    <li><a href="/blogs/posts/staff/">Staff Posts</a></li>
                    <li><a href="/blogs/photos/">Blog Photos</a></li>
                    <li><a href="/blogs/videos/">Blog Videos</a></li>
                </ul>
            </nav>
        </div>
    </div>
    <span class="menu-close"></span>
</div>

                </nav>
            </div>
        
        <!-- create page for dynamic weather five-day forecast -->
        

<div id="forecast" class="mod forecast">

    <div class="mod fc-lead">
        <h1 class="alert-title">Weather</h1>
        <h2 class="alert-sub">The latest extended forecast from The Weather Channel</h2>
        <p><a class="exp-close" href="#" onclick="close_weather();">Remove this weather forecast</a></p>
        <div class="weather-related">
            <h1 class="alert-title">Related content</h1>
            
            <div class="pass-link"><a href="/webcams/">Webcams&nbsp;&raquo;</a></div>
        </div>
    </div><!-- /end .mod.fc-lead -->
    <div class="fc-main">

        
        

        
        <div class="mod fc-day ">
            <h3 class="fc-day-name">Today</h3>
            <p class="fc-status"><span class="wicon fg"></span>
                <span class="min">Hi</span><span class="fc-ntemp">51</span><abbr title="Degrees Fahrenheit">°</abbr> 
                 <em>Areas Fog then Sunny</em></p>
        </div>
        
        <div class="mod fc-day ">
            <h3 class="fc-day-name">Tonight</h3>
            <p class="fc-status"><span class="wicon nbkn"></span>
                <span class="min">Lo</span><span class="fc-ntemp">32</span><abbr title="Degrees Fahrenheit">°</abbr> 
                 <em>Increasing Clouds</em></p>
        </div>
        
        <div class="mod fc-day ">
            <h3 class="fc-day-name">Saturday</h3>
            <p class="fc-status"><span class="wicon ra"></span>
                <span class="min">Hi</span><span class="fc-ntemp">42</span><abbr title="Degrees Fahrenheit">°</abbr> 
                 <em>Chance Rain</em></p>
        </div>
        
        <div class="mod fc-day ">
            <h3 class="fc-day-name">Saturday Night</h3>
            <p class="fc-status"><span class="wicon nra"></span>
                <span class="min">Lo</span><span class="fc-ntemp">35</span><abbr title="Degrees Fahrenheit">°</abbr> 
                 <em>Chance Rain</em></p>
        </div>
        
        <div class="mod fc-day ">
            <h3 class="fc-day-name">Sunday</h3>
            <p class="fc-status"><span class="wicon shra"></span>
                <span class="min">Hi</span><span class="fc-ntemp">49</span><abbr title="Degrees Fahrenheit">°</abbr> 
                 <em>Slight Chance Showers</em></p>
        </div>
        
        <div class="mod fc-day ">
            <h3 class="fc-day-name">Sunday Night</h3>
            <p class="fc-status"><span class="wicon nshra"></span>
                <span class="min">Lo</span><span class="fc-ntemp">36</span><abbr title="Degrees Fahrenheit">°</abbr> 
                 <em>Chance Showers</em></p>
        </div>
        
        <div class="mod fc-day ">
            <h3 class="fc-day-name">Monday</h3>
            <p class="fc-status"><span class="wicon ra"></span>
                <span class="min">Hi</span><span class="fc-ntemp">51</span><abbr title="Degrees Fahrenheit">°</abbr> 
                 <em>Chance Rain</em></p>
        </div>
        
        <div class="mod fc-day ">
            <h3 class="fc-day-name">Monday Night</h3>
            <p class="fc-status"><span class="wicon nshra"></span>
                <span class="min">Lo</span><span class="fc-ntemp">38</span><abbr title="Degrees Fahrenheit">°</abbr> 
                 <em>Showers Likely</em></p>
        </div>
        
        <div class="mod fc-day ">
            <h3 class="fc-day-name">Tuesday</h3>
            <p class="fc-status"><span class="wicon shra"></span>
                <span class="min">Hi</span><span class="fc-ntemp">54</span><abbr title="Degrees Fahrenheit">°</abbr> 
                 <em>Slight Chance Showers</em></p>
        </div>
        
        <div class="mod fc-day  fc-last">
            <h3 class="fc-day-name">Tuesday Night</h3>
            <p class="fc-status"><span class="wicon nshra"></span>
                <span class="min">Lo</span><span class="fc-ntemp">35</span><abbr title="Degrees Fahrenheit">°</abbr> 
                 <em>Slight Chance Showers</em></p>
        </div>
        
    </div>
</div>
        
        </header>
        

        
        
<div id="top-banner" class="sbanner">
    
    <!-- /1678726/WWPW_Leaderboard_Story_728x90 -->
    <div id='div-gpt-ad-1469117380559-0' style='height:90px; width:728px;margin:0 auto;'>
    <script type='text/javascript'>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469117380559-0'); });
    </script>
    </div>
    
</div>

        

        <div id="content-wrap" class="container-fluid">
            
            

            

<div class="row-fluid">
    <section class="span8">

        

        
        <div id="seclinks" class="span2">
            <nav data-sectionname="sports/" class="section-nav " id="section-nav">
                <h1><b>More for you</b><i>:</i><a href="/news/sports/">Sports</a></h1>
                <ul>
                    
<li><a href="/news/2017/mar/10/huskies8217-season-ends-with-pac-12-tournament-loss-to-usc/">Huskies&#8217; season ends with Pac-12 tournament loss to&nbsp;<span class="caps">USC</span>&nbsp;</a></li>
<li><a href="/news/2017/mar/10/texans-trade-osweiler-to-browns/">Texans trade Osweiler to&nbsp;Browns&nbsp;</a></li>
<li><a href="/news/2017/mar/10/eagles-sign-wr-jeffery/">Eagles sign <span class="caps">WR</span>&nbsp;Jeffery&nbsp;</a></li>
<li><a href="/news/2017/mar/10/cowboys-shopping-romo-no-plan-to-release-qb/">Cowboys shopping Romo, no plan to release&nbsp;<span class="caps">QB</span>&nbsp;</a></li>
<li><a href="/news/2017/mar/10/chargers-sign-former-seahawk-ol-okung/">Chargers sign former Seahawk <span class="caps">OL</span>&nbsp;Okung&nbsp;</a></li>
<li><a href="/news/2017/mar/10/reports-seahawks-sign-joeckel-to-add-to-offensive-line/">Reports: Seahawks sign Joeckel to add to offensive&nbsp;line&nbsp;</a></li>
<li><a href="/news/2017/mar/09/winter-2017-collegians-how-they-fared/">Winter 2017 collegians: How they&nbsp;fared&nbsp;</a></li>
<li><a href="/news/2017/mar/09/gonzaga8217s-wcc-reign-continues/">Gonzaga&#8217;s <span class="caps">WCC</span> reign&nbsp;continues&nbsp;</a></li>
<li><a href="/news/2017/mar/09/wsu-blows-big-halftime-lead-falls-to-colorado/"><span class="caps">WSU</span> blows big halftime lead, falls to&nbsp;Colorado&nbsp;</a></li>
<li><a href="/news/2017/mar/09/cowboys-to-release-romo/">Cowboys to release&nbsp;Romo&nbsp;</a></li>
<li><a href="/news/2017/mar/09/taylor-to-return-to-buffalo-on-restructured-deal/">Taylor to return to Buffalo on restructured&nbsp;deal&nbsp;</a></li>
<li><a href="/news/2017/mar/09/marshall-switches-colors-signs-on-with-giants/">Marshall switches colors, signs on with&nbsp;Giants&nbsp;</a></li>
<li><a href="/news/2017/mar/09/sounders-looking-to-avoid-repeat-of-season-opener-in-montreal/">Sounders looking to avoid repeat of season opener in&nbsp;Montreal&nbsp;</a></li>
<li><a href="/news/2017/mar/09/mariners-utility-and-backup-outfielder-competitions-set-to-intensify/">Mariners utility and backup outfielder competitions set to&nbsp;intensify&nbsp;</a></li>
<li><a href="/news/2017/mar/09/reports-seattle-could-be-8216desirable-landing-spot8217-for-peterson/">Reports: Seattle could be &#8216;desirable landing spot&#8217; for&nbsp;Peterson&nbsp;</a></li>
                </ul>
            </nav>
        </div>
        

        
            <article class="span10 clearfix">

                

<header>
	
    <h1 class="headline">Huskies&#8217; season ends with Pac-12 tournament loss to&nbsp;<span class="caps">USC</span></h1>
    <div class="meta">
        <div class="byline"><cite class="byline"><span class="by">by </span><span class="author">Christian Caple</span><span class="byline-title">The (Tacoma) News Tribune</span></cite></div>
        <div class="pubdate"><time pubdate datetime="2017-03-10T07:18:08.298052-08:00" title="March 10, 2017, 7:18 a.m.">March 10, 2017, 7:18 a.m.</time></div>
        <div class="tags"><i class="icon-tags"></i> <a href="/news/tags/college-sports/">College Sports</a></div>
                    <!-- AddThis Button BEGIN -->
            <div class="addthis_toolbox addthis_default_style addthis_16x16_style">
            <a class="addthis_button_facebook"></a>
            <a class="addthis_button_twitter"></a>
            <a class="addthis_button_pinterest_share"></a>
            <a class="addthis_button_google_plusone_share"></a>
            <a class="addthis_button_compact"></a><a class="addthis_counter addthis_bubble_style"></a>
            </div>
            <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4fda60746cad190f"></script>
            <!-- AddThis Button END -->
            <!-- send to Kindle -->
            <div class="kindleWidget" style="display:inline-block;position:relative;padding:0 3px;cursor:pointer;font-size:9px;font-family:Arial;white-space:nowrap;line-height:1;border-radius:3px;border:#ccc thin solid;color:black;background:transparent url('https://d1xnn692s7u6t6.cloudfront.net/button-gradient.png') repeat-x;background-size:contain;top: -3px;"><img style="vertical-align:middle;margin:0;padding:0;border:none;" src="https://d1xnn692s7u6t6.cloudfront.net/white-15.png" /><span style="vertical-align:middle;margin-left:3px;">Send to Kindle</span></div>
            <!-- send to Kindle END -->
            <span class="print-this"><a href="javascript:window.print()"><img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/storyprint.png" width="48" height="16" alt="Print This" /></a></span>

    </div>
</header>

                <div class="body">
                    <p>LAS VEGAS &mdash; It's over.</p> <p>Finally, mercifully, after 13 consecutive losses and counting, after so many empty offensive possessions and so many turnovers and so much lackluster defense, the Washington Huskies are finished with this mess of a men&rsquo;s basketball season.</p> <p>They laid the catastrophe to rest with another inevitable defeat, this one 78-73 to the USC Trojans on Wednesday night in the first round of the Pac-12 tournament at the mostly empty T-Mobile Arena, 49 days now separating them&hellip;
                    <div class="subscribe-msg">
                        <div class="button-well">
                            <div class="hard-msg">
                                <p class="hard-em">Stay with the story. Get full access to The Wenatchee World online for just pennies a day!</p>
                                <ul>
                                    <li><span>For as little as 27 cents a day, you can have complete access to all the local news, photos and video content from North Central Washington's primary news source.</span></li>
                                    <li><span>Read on any device, whether smartphone, tablet or computer.</span></li>
                                    <li><span>Your online access is <strong>free</strong> with any print subscription. Or, subscribe online only by the month or year.</span></li>
                                    <li><span><em>Note: If you are already a print subscriber but haven't yet activated your online account, <a href="/subscribe/?next=/news/2017/mar/10/huskies8217-season-ends-with-pac-12-tournament-loss-to-usc/&amp;activate=1">click here</a> to complete the activation process.</em></span></li>
                                </ul>
                            </div>
                        </div>
                        <div class="hard-img">
                            <img src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/img/ui/subscribe/print-monthly.png" alt="Subscribe" />
                        </div>
                    </div>
                </div>
                <p><a href="/subscribe/?next=/news/2017/mar/10/huskies8217-season-ends-with-pac-12-tournament-loss-to-usc/" class="btn btn-primary btn-large">View my options</a>
                
                <span class="or">or</span>
                <a href="/accounts/signin/?next=/news/2017/mar/10/huskies8217-season-ends-with-pac-12-tournament-loss-to-usc/" class="btn btn-primary btn-large">Sign in</a>
                
                </p>
                <script>
                $(document).ready(function () {
                    $("nav.utils a.sign-in").attr("href", "/accounts/signin/?next=/news/2017/mar/10/huskies8217-season-ends-with-pac-12-tournament-loss-to-usc/");
                });
                </script>
            </article>
            
    </section>
    <div class="sidebar span4">

        <div class="box-ads-1">
            
            <p><small>Advertisements</small></p>
            <div id="ad_spot" class="ad ad-left">
                <!-- /1678726/WW_Bigbox_Story_300x250 -->
                <div id='div-gpt-ad-1469117380559-1' style='height:250px; width:300px;'>
                <script type='text/javascript'>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469117380559-1'); });
                </script>
                </div>
            </div>
            <div id="ad_ros" class="ad ad-right">
                <!-- /1678726/WW_Bigbox_Story_ROS_300x250 -->
                <div id='div-gpt-ad-1469117380559-2' style='height:250px; width:300px;'>
                <script type='text/javascript'>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469117380559-2'); });
                </script>
                </div>
            </div>
            <div id="ad_house" class="ad house-ad ad-left">
                <!-- /1678726/WW_Bigbox_Story_House_300x250 -->
                <div id='div-gpt-ad-1469117380559-3' style='height:250px; width:300px;'>
                <script type='text/javascript'>
                googletag.cmd.push(function() { googletag.display('div-gpt-ad-1469117380559-3'); });
                </script>
                </div>
            </div>
            
        </div>

    </div>
    <div id="img-layer" class="testimg">&nbsp;</div>
</div>


        </div> <!-- /container -->
            
            <!-- create urls for links in footer.html -->
            <footer class="navbar-footer">
    <div class="row-fluid">
        <div class="span3">
            <h1>SOCIAL</h1>
            <ul class="footlink social-link">
                <li><a class="social facebook-icon" href="https://www.facebook.com/wenatcheeworld" target="_blank">Facebook</a></li>
                <li><a class="social twitter-icon" href="http://twitter.com/wenatcheeworld" target="_blank">Twitter</a></li>
                <li><a class="social pinterest-icon" href="http://pinterest.com/wenatcheeworld" target="_blank">Pinterest</a></li>
                <li><a class="social instagram-icon" href="http://instagram.com/wenatcheeworld" target="_blank">Instagram</a></li>
            </ul>
            <h1>APPS</h1>
            <ul class="footlink social-link">
                <li><a class="social apple-icon" href="http://wwrld.us/appdwnld1" target="_blank">Apple iOS</a></li>
                <li><a class="social googleplay-icon" href="http://wwrld.us/ggplydwnld" target="_blank">Google Play</a></li>
            </ul>
        </div>
        <div class="span3">
            <h1>SERVICES</h1>
            <ul class="footlink">
                <li><a href="/subscribe/"><strong>Subscribe</strong></a></li>
                <li><a href="/make-payment/"><strong>Make a Payment</strong></a></li>
                <li><a href="/digital/"><strong>Digital Edition</strong></a></li>
                <li><a href="/vip-world/register/">E-mail Newsletters</a></li>
                <li><a href="/nie/">Newspaper in Education</a></li>
                <li><a href="/special/">Special Publications</a></li>
                <li><a href="/commercialprint/">Commercial Print</a></li>
                <li><a href="/adv/main/">Advertise With Us</a></li>
            </ul>
            <h1>CALENDAR</h1>
            <ul class="footlink">
                <li><a href="http://www.ncwcalendar.com" target="_blank">NCW Calendar</a></li>
                <li><a href="http://www.ncwcalendar.com/submit-event/" target="_blank">Add an Event</a></li>
            </ul>
        </div>
         <div class="span3">
            <h1>CONTACT US</h1>
            <ul class="footlink">
                <li><a href="/contact/delivery/"><strong>Paper Delivery Issue</strong></a></li>
                <li><a href="/wos/">World of Savings</a></li>
                <li><a href="/anniversary/submit/">Anniversaries</a></li>
                <li><a href="/engagement/submit/">Engagements</a></li>
                <li><a href="/wedding/submit/">Weddings</a></li>
                <li><a href="/vacation-stop/">Vacation Stop</a></li>
                <li><a href="/opinion/submit/">Letter to the Editor</a></li>
                <li><a href="/staff/">Staff Directory</a></li>
                <li><a href="/contact/">Contact Us</a></li>
            </ul>
            <h1>MULTIMEDIA</h1>
            <ul class="footlink">
                <li><a href="/videos/">Videos</a></li>
                <li><a href="/photos/">Photos</a></li>
                <li><a href="/photos/galleries/">Photo Galleries</a></li>
                <li><a href="/webcams/">Webcams</a>
            </ul>
        </div>
         <div class="span3">
            <h1>CLASSIFIEDS</h1>
            <ul class="footlink">
                <li><a href="http://homes.wenatcheeworld.com" target="_blank">Homes</a></li>
                <li><a href="http://classifieds.wenatcheeworld.com/wenatchee/employment/search" target="_blank">Jobs</a></li>
                <li><a href="http://ncwbusinessdirectory.com" target="_blank">Business</a></li>
                <li><a href="http://classifieds.wenatcheeworld.com" target="_blank">Classifieds</a></li>
            </ul>
            <h1>PARTNERS</h1>
            <ul class="footlink">
                <li><a href="http://artofcommunityncw.com/" target="_blank"><strong>The Art of Community NCW</strong></a></li>
                <li><a href="http://ncwfoothills.com" target="_blank">Foothills Magazine</a></li>
                <li><a href="http://www.wenatcheeworld.com/lctw/" target="_blank">Lake Chelan This Week</a></li>
                <li><a href="http://wellness.wenatcheeworld.com" target="_blank">Medical, Health &amp; Wellness Directory</a></li>
                <li><a href="http://qvpr.com" target="_blank">Quincy Valley Post-Register</a></li>
                <li><a href="/wapost/">The Washington Post National Weekly</a></li>
                <li><a href="http://wenatcheemomblog.com" target="_blank">Wenatchee Mom Blog</a></li>
                <li><a href="http://wvbusinessworld.com" target="_blank">Wenatchee Valley Business World</a></li>
            </ul>
        </div>
    </div>
    <div class="row-fluid">
        <div class="footer-c"><ul><li>&copy; The Wenatchee World 2017</li><li class="terms"><a href="/terms/">Terms of Use</a></li><li class="terms"><a href="/forumstandards/">Forum Standards</a></li><li class="terms"><a href="/privacy/">Privacy Policy</a></li></ul></div>
    </div>
</footer>

            

        
        <!-- Le javascript
        ================================================== -->
        <!-- Placed at the end of the document so the pages load faster -->
        <script type="text/javascript" src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/CACHE/js/88159346ac59.js"></script>
        
    <script type="text/javascript" src="//s3-us-west-2.amazonaws.com/assets.www.wenatcheeworld.com/static/CACHE/js/173c8843fbb7.js"></script>
    <!-- <script type="text/javascript" src="http://wenatcheeworld.mycapture.com/mycapture/scripts/remote-1.1.asp"></script> -->
    <script type="text/javascript" src="https://d1xnn692s7u6t6.cloudfront.net/widget.js"></script>
    <script type="text/javascript">(function k(){window.$SendToKindle&&window.$SendToKindle.Widget?$SendToKindle.Widget.init({"content":"article.span10","exclude":"header","title":"headline","author":"byline-title","published":"pubdate"}):setTimeout(k,500);})();</script>

    
    <script>

    
    $(function() {
        $('body.article-detail .sidebar').prepend($("#content-wrap .related-articles"));
        $("#content-wrap .related-articles").show();
        // hide subscription popup on close
        $('.paywall_popup_close').click(function(){
            $('.paywall_popup').hide();
        });
    });
    </script>
    

        </div>
    </body>
</html>